RMSPos - Point of Sale connectivity failures.

Incident Report for RMS Cloud

Resolved

We have rolled back to the previous environment and all affected systems are now back to normal.
We also confirm that all relevant charges have parsed correctly.

Please note: any changes made in the back-office between 00:12 AM and 9:43 AM AEDT on 22/10/2025 have been reversed and will need to be reapplied.

Thank you for your patience while we completed the rollback and verification.
If you notice anything unusual or require further follow-up please contact the local support team
Posted Oct 23, 2025 - 06:06 UTC

Monitoring

We have completed the rollback and reverted to the previous environment.
Our engineers are now monitoring all services closely to ensure stability and a return to full functionality.

We’ll provide another update shortly once we’ve confirmed that all systems are operating normally and will follow up with a full post-incident summary.

Thank you for your patience.
Posted Oct 23, 2025 - 02:18 UTC

Update

We have been unable to fully identify the root cause of the issue affecting our systems.
As such, we will now be rolling back to the previous environment.

Please note that any changes made in the back-office since 00:12 AM (AEDT) on 22/10/2025 will be reversed and will need to be reapplied.

We apologise for the inconvenience this has caused and appreciate your patience as we restore full service. We will send another update once rollback is complete and we have further information.
Posted Oct 23, 2025 - 02:03 UTC

Update

RMS Engineers are actively working with the SwiftPOS team to investigate and resolve the issue. We’ll provide another update as soon as more information becomes available.
Posted Oct 23, 2025 - 01:17 UTC

Update

We are continuing to investigate this issue.
Posted Oct 22, 2025 - 21:18 UTC

Investigating

We are currently investigating an issue where the POS Back Office is unable to communicate with front-of-house POS devices. Users will be unable to perform end-of-day (EOD) processing, generate back-office reports, or update terminals.
Posted Oct 22, 2025 - 07:00 UTC
This incident affected: Australia (RMS ePOS).