RMS 9+ Product Release (LIVE)
Incident Report for RMS Cloud
Resolved
RMS 9+ Product Update: Completed.
Posted Apr 16, 2024 - 21:24 UTC
Investigating
RMS 9+ Product Update. The Update can take up to 30 minutes to fully complete, during the update users may be required to log back into RMS 9+.

For full details of what is included in the latest update please refer to the Help Menu > Release Notes from within the RMS 9+ application.

Release Region - APAC, CHINA
Posted Apr 16, 2024 - 21:22 UTC
This incident affected: Australia (RMS9+ (Live)) and China (RMS9+ (Live)).